2019/04/15

Troubleshoot HSRP

6
R1:
interface Ethernet0/0
 ip address 10.10.1.2 255.255.255.0
 standby 1 ip 10.10.1.1
!
interface Ethernet0/1
 ip address 10.1.1.2 255.255.255.252



R2:
interface Ethernet0/0
 ip address 10.10.1.3 255.255.255.0
 standby version 2
 standby 2 ip 10.10.1.1
!
interface Ethernet0/1
 ip address 10.1.1.6 255.255.255.0
!

R1#sh standby brief
Interface   Grp  Pri P State   Active        Standby         Virtual IP
Et0/0         1     100   Active  local          unknown       10.10.1.1


R2#sh standby brief
Interface   Grp  Pri P State   Active        Standby         Virtual IP
Et0/0         2     100   Active  local         unknown         10.10.1.1


R2(config)#int e0/0
R2(config-if)#standby 1 ip 10.10.1.1
% Address 10.10.1.1 in group 2

R2#
*Apr 15 18:52:36.981: %IP-4-DUPADDR: Duplicate address 10.10.1.1 on Ethernet0/0, sourced by 0000.0c07.ac01

R2(config-if)#no standby 2

R2(config)#int e0/0
R2(config-if)#standby 1 ip 10.10.1.1
R2#sh standby brief
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Et0/0       1    100   Listen  unknown         unknown         10.10.1.1


R2#
*Apr 15 18:57:46.324: %HSRP-5-STATECHANGE: Ethernet0/0 Grp 1 state Standby -> Active
R2#
*Apr 15 18:57:46.334: %IP-4-DUPADDR: Duplicate address 10.10.1.1 on Ethernet0/0, sourced by 0000.0c07.ac01

R2#sh standby brief
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Et0/0       1    100   Active  local           unknown         10.10.1.1


R1(config)#int e0/0
R1(config-if)#standby 1 priority 150
R1(config-if)#standby 1 preempt
R1#sh standby brief
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Et0/0       1    150 P Active  local           unknown         10.10.1.1

R1#sh standby
Ethernet0/0 - Group 1
  State is Active
    2 state changes, last state change 00:22:29
  Virtual IP address is 10.10.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.384 secs
  Preemption enabled
  Active router is local
  Standby router is unknown
  Priority 150 (configured 150)
  Group name is "hsrp-Et0/0-1" (default)

R2#sh standby
Ethernet0/0 - Group 1 (version 2)
  State is Active
    2 state changes, last state change 00:01:48
  Virtual IP address is 10.10.1.1
  Active virtual MAC address is 0000.0c9f.f001
    Local virtual MAC address is 0000.0c9f.f001 (v2 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.192 secs
  Preemption disabled
  Active router is local
  Standby router is unknown
  Priority 100 (default 100)
  Group name is "hsrp-Et0/0-1" (default)

R2(config)#int e0/0
R2(config-if)#no standby version 2
R2(config-if)#do sh stand
Ethernet0/0 - Group 1
  State is Standby
    4 state changes, last state change 00:00:10
  Virtual IP address is 10.10.1.1
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (v1 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.528 secs
  Preemption disabled
  Active router is 10.10.1.2, priority 150 (expires in 8.816 sec)
  Standby router is local
  Priority 100 (default 100)
  Group name is "hsrp-Et0/0-1" (default)

R2(config-if)#do sh stand br
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Et0/0       1    100   Standby 10.10.1.2       local           10.10.1.1

R1#sh standby b
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Et0/0       1    150 P Active  local           10.10.1.3       10.10.1.1


沒有留言: